2022-09-26, 00:03 *
Welcome, Guest. Please login or register.

Login with username, password and session length
Pages: [1]
Author Topic: Getting errors when I start up (User Interface is version 6..")  (Read 6622 times)
0 Members and 1 Guest are viewing this topic.
« on: 2005-11-01, 07:11 »

Hi,  I'm having trouble starting up Generations.  After I try to start Generations, it gives me an error saying: "User Interface is version 6, expected 3" in the console.

I've installed Q3 Arena along with the 1.32 point release.  After that, I installed the Generations setup "e" and then the "f" update.

Can anyone help me out?  Thanks!
Bird of Fire

Team Member
Elite (7.5k+)
Posts: 8644

« Reply #1 on: 2005-11-01, 07:33 »

Version 6 is the correct UI_API_VERSION value for Generations Arena.  It should not be expecting version 3 at all.  It sounds like something is set in baseq3's q3config.cfg that might be interfering with the User Interface load for Gen.  Are you starting Generations using a shortcut, or the "mods" menu?  Double check your console in Quak3 III Arena to be sure it's reporting version 1.32 just in case the patch didn't install properly.  Also, if you could let me know the contents of the following files:


I'll do what I can to get you up and running.  Thanks.

I fly into the night, on wings of fire burning bright...
« Reply #2 on: 2005-11-01, 15:19 »

Phoenix,  thanks for your quick reply.

By the way, I can't even start up Q3 Arena without getting ths same error. Slipgate - Sad

Here's the contents of my generations/autoexec.cfg:

// Created by Generations Arena.  Please do not modify.

set model visor
set team_model visor
set headmodel visor
set team_headmodel visor

seta ui_menuFiles "ui/menus.txt"
seta ui_netSource "2"

seta r_maxpolys 8192
seta r_maxpolyverts 32768
seta r_znear 1
seta g_teamAutoJoin 0
seta sv_pure 1
seta sv_floodprotect 0
seta g_quadfactor 4
seta cg_redTeam "Red"
seta cg_blueTeam "Blue"
seta dmflags "64"
seta g_botsoff "0"

seta sv_master2 "master0.gamespy.com"
seta sv_master3 "master.gamespy.com:27900"
seta sv_master4 ""


My generations/q3config.cfg:

// generated by quake, do not modify
bind TAB "+scores"
bind ENTER "+button2"
bind ESCAPE "togglemenu"
bind SPACE "+moveup"
bind + "sizeup"
bind - "sizedown"
bind / "weapnext"
bind 0 "weapon 10"
bind 1 "weapon 1"
bind 2 "weapon 2"
bind 3 "weapon 3"
bind 4 "weapon 4"
bind 5 "weapon 5"
bind 6 "weapon 6"
bind 7 "weapon 7"
bind 8 "weapon 8"
bind 9 "weapon 9"
bind = "sizeup"
bind [ "weapprev"
bind  "+mlook"
bind ] "weapnext"
bind _ "sizedown"
bind ` "toggleconsole"
bind a "+moveleft"
bind c "+movedown"
bind d "+moveright"
bind s "+back"
bind t "messagemode"
bind w "+forward"
bind ~ "toggleconsole"
bind PAUSE "pause"
bind UPARROW "+forward"
bind DOWNARROW "+back"
bind LEFTARROW "+left"
bind RIGHTARROW "+right"
bind ALT "+strafe"
bind CTRL "+attack"
bind SHIFT "+speed"
bind DEL "+lookdown"
bind PGDN "+lookup"
bind END "centerview"
bind F1 "vote yes"
bind F2 "vote no"
bind F3 "ui_teamorders"
bind F11 "screenshot"
bind MOUSE1 "+attack"
bind MOUSE2 "+strafe"
bind MOUSE3 "+zoom"
bind MWHEELDOWN "weapnext"
bind MWHEELUP "weapprev"
seta server16 ""
seta server15 ""
seta server14 ""
seta server13 ""
seta server12 ""
seta server11 ""
seta server10 ""
seta server9 ""
seta server8 ""
seta server7 ""
seta server6 ""
seta server5 ""
seta server4 ""
seta server3 ""
seta server2 ""
seta server1 ""
seta cg_marks "1"
seta cg_drawCrosshairNames "1"
seta cg_drawCrosshair "4"
seta cg_brassTime "1250"
seta ui_master "0"
seta g_spSkill "2"
seta g_spVideos ""
seta g_spAwards ""
seta g_spScores5 ""
seta g_spScores4 ""
seta g_spScores3 ""
seta g_spScores2 ""
seta g_spScores1 ""
seta ui_ctf_friendly "0"
seta ui_ctf_timelimit "30"
seta ui_ctf_capturelimit "8"
seta ui_team_friendly "1"
seta ui_team_timelimit "20"
seta ui_team_fraglimit "0"
seta ui_tourney_timelimit "15"
seta ui_tourney_fraglimit "0"
seta ui_ffa_timelimit "0"
seta ui_ffa_fraglimit "20"
seta s_occ_eq "0.75"
seta s_occfactor "0.5"
seta s_bloat "2.0"
seta s_numpolys "400"
seta s_polyreflectsize "10000000"
seta s_polysize "10000000"
seta s_polykeep "1000000000"
seta s_refdelay "2.0"
seta s_refgain "0.45"
seta s_leafnum "0"
seta s_max_distance "1000.0"
seta s_min_distance "3.0"
seta s_distance "100.0"
seta s_doppler "1.0"
seta s_rolloff "1.0"
seta s_mixPreStep "0.05"
seta s_mixahead "0.2"
seta s_loadas8bit "1"
seta s_khz "22"
seta s_separation "0.5"
seta s_musicvolume "0.25"
seta s_volume "0.7"
seta vid_ypos "22"
seta vid_xpos "3"
seta r_lastValidRenderer "MOBILITY RADEON 9600 x86/SSE2"
seta r_primitives "0"
seta r_railSegmentLength "32"
seta r_railCoreWidth "6"
seta r_railWidth "16"
seta r_facePlaneCull "1"
seta r_gamma "1"
seta r_swapInterval "0"
seta r_textureMode "GL_LINEAR_MIPMAP_NEAREST"
seta r_finish "0"
seta r_dlightBacks "1"
seta r_dynamiclight "1"
seta r_drawSun "0"
seta r_fastsky "0"
seta r_ignoreGLErrors "1"
seta r_flares "0"
seta r_lodbias "0"
seta r_lodCurveError "250"
seta r_ignoreFastPath "1"
seta r_smp "0"
seta r_subdivisions "4"
seta r_vertexLight "0"
seta r_simpleMipMaps "1"
seta r_customaspect "1"
seta r_customheight "1024"
seta r_customwidth "1600"
seta r_fullscreen "1"
seta r_mode "3"
seta r_ignorehwgamma "0"
seta r_overBrightBits "1"
seta r_depthbits "0"
seta r_stencilbits "8"
seta r_stereo "0"
seta r_colorbits "0"
seta r_texturebits "0"
seta r_detailtextures "1"
seta r_roundImagesDown "1"
seta r_picmip "1"
seta r_ext_texture_env_add "1"
seta r_ext_compiled_vertex_array "1"
seta r_ext_multitexture "1"
seta r_ext_gamma_control "1"
seta r_ext_compress_textures "1"
seta r_allowExtensions "1"
seta r_glDriver "opengl32"
seta net_socksPassword ""
seta net_socksUsername ""
seta net_socksPort "1080"
seta net_socksServer ""
seta net_socksEnabled "0"
seta net_noipx "0"
seta net_noudp "0"
seta cg_viewsize "100"
seta cg_predictItems "1"
seta sex "male"
seta handicap "100"
seta color "4"
seta model "visor"
seta snaps "20"
seta rate "25000"
seta name "UnnamedPlayer"
seta cl_maxPing "800"
seta m_filter "0"
seta m_side "0.25"
seta m_forward "0.25"
seta m_yaw "0.022"
seta m_pitch "0.022"
seta cg_autoswitch "1"
seta cl_mouseAccel "0"
seta sensitivity "5"
seta cl_run "1"
seta cl_packetdup "1"
seta cl_maxpackets "30"
seta cl_pitchspeed "140"
seta cl_yawspeed "140"
seta cl_cdkey "**************"
seta sv_master5 ""
seta sv_master4 ""
seta sv_master3 "master.gamespy.com:27900"
seta sv_master2 "master0.gamespy.com"
seta sv_floodProtect "0"
seta sv_maxRate "0"
seta sv_hostname "noname"
seta vm_ui "0"
seta vm_game "0"
seta vm_cgame "0"
seta joy_threshold "0.15"
seta in_joyBallScale "0.02"
seta in_joystick "0"
seta in_mouse "1"
seta in_mididevice "0"
seta in_midichannel "1"
seta in_midiport "1"
seta in_midi "0"
seta com_introplayed "1"
seta com_blood "1"
seta com_maxfps "85"
seta ui_menuFiles "ui/menus.txt"
seta ui_netSource "2"
seta r_maxpolys "8192"
seta r_maxpolyverts "32768"
seta r_znear "1"
seta g_teamAutoJoin "0"
seta sv_pure "1"
seta g_quadfactor "4"
seta cg_redTeam "Red"
seta cg_blueTeam "Blue"
seta dmflags "64"
seta g_botsoff "0"
seta com_hunkMegs "56"
« Last Edit: 2005-11-01, 17:50 by Phoenix » Logged
Bird of Fire

Team Member
Elite (7.5k+)
Posts: 8644

« Reply #3 on: 2005-11-01, 18:05 »

Quote from: webmonkey8
By the way, I can't even start up Q3 Arena without getting ths same error. Slipgate - Sad
It looks like your q3config is from an older version of Q3.  cl_cdkey isn't used anymore, the key being stored in the q3key in baseq3.  I took the liberty of remarking out the key value so nobody tries to swipe it, so the *********** value is my doing.  That's not a misprint on your part.

It sounds like your quake3 install did not update properly when you applied the 1.32 patch.  You may have the proper pk3 files in baseq3, but everything is pointing to an older version of the executable trying to load a newer version of the user interface.  A quick way to find out if your Q3 executable version is correct is to start up Quake 3 Arena and watch the blue console screen.  The very first line it prints should be this:

Q3 1.32 win-x86 Oct  7 2002

If the console goes away too fast to read it, create a shortcut to Quake3.exe with the following arguments:

"C:Your Quake3 Folderquake3.exe" +set dedicated 1

Where "Your Quake 3 Folder" is wherever you have Quake 3 installed.  Run the shortcut.  Once the console stops printing text, scroll all the way to the top and read the first line.  If the slider misbehaves try clicking the space above the slider until it reaches the top and it'll stay put (if you drag it, it will drop back to the bottom as soon as you release the mouse button).  If the first line is something other than "Q3 1.32 win-x86" with some kind of date, then the executable is the wrong version and you need to reinstall the patch for sure.
« Last Edit: 2005-11-01, 18:05 by Phoenix » Logged

I fly into the night, on wings of fire burning bright...
Pages: [1]
Jump to: