2017-12-12, 22:30 *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
Pages: [1]
  Print  
Author Topic: hunk allocation issues (only version 99d works =0()  (Read 6269 times)
0 Members and 1 Guest are viewing this topic.
daniel
 
Guest
« on: 2006-07-31, 06:11 »

howdy

it seems like only version 99d of Gen Arena works except for the map Decidia (forest)
also when i upgraded to 99e NO LEVEL worked and I kept getting HUNK_ALLOC and HUNK_ALLOCTempMemory failure messages. I got 99f and the same thing happens. I tried changing my hunkmegs in 99f but it stays at 128. No matter what I set my hunkmegs to I keep getting this error.

Please help!

                                                                                                                        Dan
Logged
Moshman
 
Beta Tester
Vadrigar
**********
Posts: 615

Yarg!

« Reply #1 on: 2006-07-31, 06:17 »

What method did you use for memory allocation setting changes?

And, I would just remove the "generations" folder, and download the full .99f, and reinstall, and run the shortcut that the gen setup placed on your desktop, works alot better than those shitty upgrades, at least when you put in the full .99f install, its fresh and should have the mem alloc settings set for you then.
Logged

Guest
 
Guest
« Reply #2 on: 2006-07-31, 06:23 »

i pulled down the console and latched. how else can i change hunkmegs?
Logged
Guest
 
Guest
« Reply #3 on: 2006-07-31, 06:24 »

oops. that was me, daniel ^
Logged
daniel
 
Guest
« Reply #4 on: 2006-07-31, 06:27 »

is there a version 99f that isn't just an upgrade?
Logged
Moshman
 
Beta Tester
Vadrigar
**********
Posts: 615

Yarg!

« Reply #5 on: 2006-07-31, 06:29 »

make a shortcut to quake3.exe.

right click > properties

target: quake3.exe +set com_hunkmegs 512
« Last Edit: 2006-07-31, 06:39 by Little Washu » Logged

Moshman
 
Beta Tester
Vadrigar
**********
Posts: 615

Yarg!

« Reply #6 on: 2006-07-31, 06:37 »

to reply to your post above mine...
I goofed, there is no .99f upgrade, you need to first install .99e then .99f.

I was thinking of .99f when I seen .99e full install on downloads page.  Sipgate - Evil  Idiot

Remove your "generations" folder...
Install .99e
Install .99f upgrade...
Logged

Phoenix
Bird of Fire
 

Team Member
Elite (7.5k+)
*********
Posts: 8353

WWW
« Reply #7 on: 2006-08-01, 02:25 »

You must first install .99e by itself, then use the .99f patch to upgrade to .99f.  If you downloaded the .99e installer program it should remove any previous versions of Generations you have installed.

The problem with hunk allocation in .99f was supposed to have been solved, but I set the value too low in the automatic checking.  I had it set to 128, which I thought at the time was high enough.  Apparently some maps are more memory hungry than others.

Here's what to do.

Start Q3 normally.  At the console, type this:
/seta com_hunkmegs 225

Close Q3.  Now, start Generations Arena.  At the console, type this:
/seta com_hunkmegs 225

Close Generations Arena.

You should now be able to play .99f.  You can change the 225 number to whatever you like above 150 or so, but I've found on some systems they do not like it being higher than 256, other systems have no problem with higher values.  It should not be more than 2/3 of your total system memory though, and if you intend to set it high, make sure you're not using a lot of memory in background progams.

The reason I say to set it in Q3 as well is, first of all, it won't hurt.  Second, if you start Gen using anything but a shortcut (such as All-Seeing Eye, etc), it may pick up the hunkmegs value in baseq3 and keep latching during load.  Doing what I recommend above WILL solve the problem.

I apoligize for the inconvenience.  I will have this issue permanently fixed in the next version.
Logged


I fly into the night, on wings of fire burning bright...
Pages: [1]
  Print  
 
Jump to: